We are currently seeing delays in processing Disbursements, Remittance, Escrow, Payouts to the following IDR destinations due to system issues with our partner.
BCA: 5000-250000000 BNI: All amount
Posted Apr 04, 2025 - 04:50 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BCA: 5000-250000000 BNI: All amount
Posted Apr 04, 2025 - 04:40 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow, Payouts to the following IDR destinations due to system issues with our partner.
BNI: All amount
Posted Apr 04, 2025 - 04:30 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-9999, above 100000001
Posted Apr 04, 2025 - 04:20 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow, Payouts to the following IDR destinations due to system issues with our partner.
BCA: 5000-250000000 BNI: All amount
Posted Apr 04, 2025 - 04:10 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: above 250000001
Posted Apr 04, 2025 - 04:00 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow, Payouts to the following IDR destinations due to system issues with our partner.
BCA: 1-4999, 5000-250000000 BNI: 1-9999, above 50000001 BRI: 10000-100000000 MANDIRI: 1-9999, above 50000001 Other banks and Ewallets: 1-9999, 50000001-250000000
Posted Apr 04, 2025 - 03:10 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: All amount MANDIRI: above 250000001
Posted Apr 03, 2025 - 23:00 WIB
This incident affected: Disbursements (BCA, BNI) and Remittance Payouts.