Dashboard Down

Incident Report for Instamoney

Resolved

Dashboard access is available again
Posted Feb 02, 2026 - 00:51 WIB

Investigating

We are currently investigating this issue.
Posted Feb 02, 2026 - 00:43 WIB
This incident affected: Dashboard.