BNI RDL Disbursement Disruption

Incident Report for Instamoney

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 17:41 WIB

Investigating

Dear Valued Customers,

We have detected issues with RDL Disbursement due to disruptions on our partner’s end.

Impact:
- Disbursements are currently being kept in pending status since 16:34 WIB until now

We deeply apologize for this disruption and are working closely with our bank partners to resolve the issue.
Posted Apr 09, 2026 - 17:23 WIB
This incident affected: RDL.