Payouts Disruption in Indonesia
Incident Report for Instamoney
Resolved
This incident has been resolved.
Posted Dec 19, 2024 - 05:50 WIB
Identified
Dear valued customers,

We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.

MANDIRI: 1-9999, above 100000001
Posted Dec 19, 2024 - 05:40 WIB
This incident affected: Disbursements (Mandiri) and Remittance Payouts.