We are currently seeing delays in processing Payouts, Disbursements to the following IDR destinations due to system issues with our partner.
BNI: All amount
Posted Nov 29, 2025 - 23:40 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: All amount
Posted Nov 29, 2025 - 23:30 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BCA: 1-1000000000 BNI: All amount
Posted Nov 29, 2025 - 23:20 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following IDR destinations due to system issues with our partner.
BNI: All amount
Posted Nov 29, 2025 - 23:00 WIB
Identified
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following IDR destinations due to system issues with our partner.
BNI: above 250000001
Posted Nov 29, 2025 - 14:10 WIB
This incident affected: Disbursements (BNI) and Remittance Payouts.