RDL Payouts Disruption

Incident Report for Instamoney

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 14:00 WIB

Identified

Dear valued customers,

We are currently seeing delays in processing RDL Payouts due to system issues with our partner.

Our team is investigating.
Posted Jun 10, 2026 - 13:25 WIB
This incident affected: Escrow (Escrow RDL) and RDL.