Disruption on Disbursement and Remittance Payout with IDR currency

Incident Report for Instamoney

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 16:46 WIB

Update

Dear Valued Customers,

All requests with currency IDR created after 3.30 PM GMT+7 will be normally processed. We are still working to reprocess the request kept in the PENDING state, which was created between 1 - 3.29 pm GMT+7.

We apologize for the inconvenience caused and will keep this status page updated.

Thank you for your cooperation

Regards,
Instamoney Customer Support
Posted Apr 16, 2025 - 16:03 WIB

Identified

Dear valued customers

We have identified the problem and currently fixing the issue

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@instamoney.co

Thank you for your understanding and cooperation.

Regards, Customer Support
Posted Apr 16, 2025 - 15:12 WIB

Investigating

Dear valued customers

We are currently observing slow processing for disbursement and remittance payouts with IDR currency.

We are currently investigating the issue.

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@instamoney.co

Thank you for your understanding and cooperation.

Regards, Customer Support
Posted Apr 16, 2025 - 14:53 WIB
This incident affected: Escrow (Escrow RDL), API (Disbursements), and Remittance Payouts.